viernes, 12 de marzo de 2010

Realtek 8172 de Toshiba A505-S69803 en Ubuntu

Voy a postear el driver y la solución a un problema que he encontrado en muchos foros y luego de probar con muchos drivers, di con uno que funciona muy bien en Ubuntu 9.10. Si bien me funciona bien en mi Toshiba A505-S69803 supongo que en la Toshiba A505-S6980 debería funcionar sin problemas ya que la única diferencia es que una tiene DDR2 y la otra DDR3.
(If you don't understand spanish, only pay attention to the link and commands lines below)

root@christian-laptop:/tmp# lspci |grep Net
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)


Kernel: (tener en cuenta que para cada actualización que haya de kernel deberán realizar nuevamente el proceso)

root@christian-laptop:/tmp# uname -a
Linux christian-laptop 2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:02:26 UTC 2010 x86_64 GNU/Linux


Bueno basicamente se bajan el driver http://www.megaupload.com/?d=H540WIS3 y lo descomprimen:
christian@christian-laptop:/tmp$ tar -xzvf rtl8192se_linux_2.6.0010.1211.2009.tar.gz
entran al directorio:
christian@christian-laptop:/tmp$ cd rtl8192se_linux_2.6.0010.1211.2009/
christian@christian-laptop:/tmp/rtl8192se_linux_2.6.0010.1211.2009$ sudo make clean
christian@christian-laptop:/tmp/rtl8192se_linux_2.6.0010.1211.2009$ sudo make
christian@christian-laptop:/tmp/rtl8192se_linux_2.6.0010.1211.2009$ sudo su
root@christian-laptop:/tmp/rtl8192se_linux_2.6.0010.1211.2009# make install
reinician la computadora:
root@christian-laptop:/tmp/rtl8192se_linux_2.6.0010.1211.2009# reboot

con eso deberia bastar para que les fucione... espero que les haya servido...

13 comentarios:

jorge dijo...

Hola Crhistian,

Tengo un Toshiba U500-1DV y como imaginarás también tengo el problema de la conexión wireless.

He seguido todos los pasos que has indicado y ahora, al menos, sí que me detecta red inhalámbraca y básicamente, introduciendo la contraseña de mi router, se conecta. Sin embargo no llega a abrir ninguna página...

¿Tienes alguna idea del problema que puede ser?

Gracias, y un saludo!!!

christian dijo...

Hola Jorge, cuando decis "introduciendo la contraseña de mi router" te referis a la clave de cifrado? que tipo de cifrado estas utilizando ? WPA2? WEP?...
Te aconsejo que hagas lo siguiente:

*- Si se logra conectar, prueba hacer un ping a la ip de tu router en mi caso por ejemplo es: ping 192.168.1.1 y fijate si contesta o no...
*- Si no se logra conectar, sacale las claves de cifrado y pruebalo sin seguridad para ver que pasa...
*- si no te conecta pero no te andan las paginas como decis proba poner en la direccion del navegador la siguietne ip: http://209.85.195.104/
si te entra a google, es porque los DNS seguramente no estan funcionando o tenes un proxy seteado que esta mal o algo por el estilo... asi que intenta cambiar los DNS con por ejemplo los de OPENDNS y cuentame que pasa.... saludos

Roberto dijo...

Hola buenas tardes amigo, estoy intentando descargar el driver pero da un error rapishare si lo puedes colocar en otros servidores por favor se te agradeceria, para intentar resolver mi problema con el wireles Toshiba A505-S6980

christian dijo...

lamentablemente ha muerto el link anterior ya lo modifique ahi te lo dejo de vuelta.. cualquier cosa avisame
saludos

Jhovany Andrés dijo...

Que tal?
Yo tengo una L505 con tarjeta realtek 8172, esperaba que me funcionara con estos pasos pero no lo he conseguido.
Al parecer tiene un problema con las redes cifradas porque al intentar conectarme a una sin seguridad lo hace casi sin problemas.
Cuando tiene clave se queda en "Obteniendo dirección de red" y luego aparece otra pantalla de autenticación con una contraseña larga rara, si le doy aceptar vuelve al estado inicial de espera, si le pongo la clave real en ese punto, deja de intentar conectarse.

No sé a que se deberá este problema, cualquier ayuda o idea estaré muy agradecido.

christian dijo...

Hola, veo que decis que te aparece otra pantalla de autenticación con una contraseña larga rara.. podrias mandarme un screenshot de la misma? me imagino que no es la del anillo de seguridad?...

Aitor dijo...

Buenas Christian,

Soy muy nuevo en esto de Linux. Hace poquito que tengo instalado este sistema operativo. He tratado de seguir los pasos que hay en tu blog para instalar los drivers, y me quedo en el comando:

christian@christian-laptop:/tmp$ tar -xzvf rtl8192se_linux_2.6.0010.1211.2009.tar.gz

Cuando escribo esto en el terminal, me dice que no existe el archivo o el directorio.

Supongo que el lugar donde te queda descargado a ti es distinto del mío (a mi por omisión los archivos descargados me van al escritorio)...

Me puedes echar una mano?

Gracias de antemano...

christian dijo...

Aitor si el archivo lo estas descargando en otra parte posicionate sobre el lugar donde lo estas descargando si es tu escritorio:
cd /home/tu_nombre_ususario/Escritorio o cd /home/tu_nombre_ususario/Desktop, o sino simplemente hacele click derecho al archivo que bajaste y le das a la opcion que dice extraer aqui y listo :). Luego continuas desde el directorio donde te los haya descomprimido con los pasos que indico... espero te sirva
saludos

Aitor dijo...

Gracias Christian,

La verdad, que después me he dado cuenta que el comando cd, me sonaba de ms dos cuando comencé a usar ordenador xDDD y por ahí he ido pillando un poco de que iba el tema y lo pude resolver. La wi-fi me va ahora perfectamente.

La tarjeta de la wi-fi, parece ser que es la misma que la de bluetooth, por que al actualizarle los drivers también me ha reconocido el otro tipo de conexión. El tema es que el portátil me reconoce el dispositivo móvil, envia un pin para que se conecten, pero ahí se queda todo...o sea, no puedo acceder a la memoria del teléfono por que este no me aparece en ninguna parte...alguna sugerencia? Por otro lado, conoces algun software que esté bien para lo que es la sincronización entre un Nokia Xpress Music y Ubuntu??? Como el PC suite para windows???

Gracias de antemano

German dijo...

christian muchas gracias funciono perfecto!!!!!

Roberto Namaste dijo...

Hola, Buenos dias, amigo hice todos los pasos que me distes pero cuando reinicio la maquina no me aparece ninguna conexion wireless si me podrias ayudar te lo agradezco de ante mano por favor, la mia es la toshiba A505-s6980 con ubuntu 9.10 64bit gracias de verdad amo ubuntu y pues ando pegado en cable y vaaa es muy fastidioso si quieres moverte. gracias

christian dijo...

prueba fijarte si al menos te da algun resultado caundo haces un escaneo de redes (cambia wlan0 por el nombre de tu interface si no te funciona).
christian@christian-laptop:~$ iwlist wlan0 scanning

Por otro lado no te ha tirado ningun error cuando hiciste la instalacion? como indico aca...
saludos

Roberto Namaste dijo...

Buenos Días, nuevamente yo =) a la final no pude nada con el wireelss de mi ubuntu9.10, estoy probando el 10.04 antes de instalar y tampoco me reconoce redes imnalambrica, ya hicistes la prueba con el nuevo ubuntu ? muchas gracias seria de ayuda un nuevo tuto con la actualizacion de ubuntu.... igual creo que lo ultimo que me dijistes es que ponga el nombre de mi wireless wlan0 si no me equivo ?